PyPI/onnx CVE-2024-7776: critical 9.1, EPSS 1.53%
A vulnerability in the `download_model` function of the onnx/onnx framework, before and including version 1.16.1, allows for arbitrary file overwrite due to inadequate prevention of path traversal att
Action: Upgrade onnx to 1.16.2 or later.
pip install onnx==1.16.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.16.2 | - |
Fixed versions
| 1.16.2 |
Sources
- osv: PYSEC-2025-10
- https://huntr.com/bounties/a7a46cf6-1fa0-454b-988c-62d222e83f63
- https://github.com/advisories/GHSA-h36j-8vv3-cj52
CVE-2024-7776 · published · modified · JSON