PyPI/django CVE-2025-59681: critical 9.8, EPSS 0.64%
An issue was discovered in Django 4.2 before 4.2.25, 5.1 before 5.1.13, and 5.2 before 5.2.7. QuerySet.annotate(), QuerySet.alias(), QuerySet.aggregate(), and QuerySet.extra() are subject to SQL injec
Action: Upgrade django to 4.2.25 or later.
pip install django==4.2.25pip install django==5.1.13pip install django==5.2.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.2 | 4.2.25 | - |
| 5.1 | 5.1.13 | - |
| 5.2 | 5.2.7 | - |
Fixed versions
| 4.2.25 | 5.1.13 | 5.2.7 |
Sources
- osv: PYSEC-2025-106
- http://www.openwall.com/lists/oss-security/2025/10/01/3
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/g/django-announce
- https://www.djangoproject.com/weblog/2025/oct/01/security-releases/
- https://github.com/advisories/GHSA-hpr9-3m2g-3j9p
CVE-2025-59681 · published · modified · JSON