PyPI/picklescan CVE-2025-10155: high 7.8, EPSS 0.85%
An Improper Input Validation vulnerability in the scanning logic of mmaitre314 picklescan versions up to and including 0.0.30 allows a remote attacker to bypass pickle files security checks by supplyi
Action: Upgrade picklescan to 0.0.31 or later.
pip install picklescan==0.0.31Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.31 | - |
Fixed versions
| 0.0.31 |
Sources
- osv: PYSEC-2025-151
- https://github.com/mmaitre314/picklescan/blob/58983e1c20973ac42f2df7ff15d7c8cd32f9b688/src/picklescan/scanner.py#L463
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-jgw4-cr84-mqxg
CVE-2025-10155 · published · modified · JSON