PyPI/picklescan CVE-2025-1716, CVE-2025-1889: critical 9.8, EPSS 1.72%
picklescan before 0.0.21 does not treat 'pip' as an unsafe global. An attacker could craft a malicious model that uses Pickle to pull in a malicious PyPI package (hosted, for example, on pypi.org or G
Action: Upgrade picklescan to 0.0.21 or later.
pip install picklescan==0.0.21Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.21 | - |
Fixed versions
| 0.0.21 |
Sources
- osv: PYSEC-2025-18
- nvd: CVE-2025-1716
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-655q-fx9r-782v
- https://github.com/mmaitre314/picklescan/commit/78ce704227c51f070c0c5fb4b466d92c62a7aa3d
- https://sites.google.com/sonatype.com/vulnerabilities/cve-2025-1716
CVE-2025-1716, CVE-2025-1889 · published · modified · JSON