PyPI/picklescan CVE-2025-1716, CVE-2025-1889: critical 9.8, EPSS 1.72%
picklescan before 0.0.22 only considers standard pickle file extensions in the scope for its vulnerability scan. An attacker could craft a malicious model that uses Pickle and include a malicious pick
Action: Upgrade picklescan to 0.0.22 or later.
pip install picklescan==0.0.22Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.22 | - |
Fixed versions
| 0.0.22 |
Sources
- osv: PYSEC-2025-19
- https://sites.google.com/sonatype.com/vulnerabilities/cve-2025-1889
- https://github.com/advisories/GHSA-769v-p64c-89pr
CVE-2025-1716, CVE-2025-1889 · published · modified · JSON