tocsin

PyPI/llama-index CVE-2025-3046: high 7.5, EPSS 0.64%

A vulnerability in the `ObsidianReader` class of the run-llama/llama_index repository, versions 0.12.23 to 0.12.28, allows for arbitrary file read through symbolic links. The `ObsidianReader` fails to

Action: Upgrade llama-index to 0.12.28 or later.

pip install llama-index==0.12.28

Affected

introducedfixedlast affected
0.12.230.12.28-

Fixed versions

0.12.28

Sources

CVE-2025-3046 · published · modified · JSON