PyPI/llama-index CVE-2025-5472: medium 6.5, EPSS 0.39%
The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Servic
Action: Upgrade llama-index to 0.12.38 or later.
pip install llama-index==0.12.38Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.12.28 | 0.12.38 | - |
Fixed versions
| 0.12.38 |
Sources
- osv: PYSEC-2025-251
- https://github.com/run-llama/llama_index/commit/c032843a02ce38fd8f284b2aa5a37fd1c17ae635
- https://huntr.com/bounties/df187bda-7911-4823-a19a-e15b2c66b0d4
CVE-2025-5472 · published · modified · JSON