tocsin

PyPI/llama-index CVE-2025-6210: medium 6.2, EPSS 0.33%

A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, specifically in version 0.12.27, allows for hardlink-based path traversal. This flaw permits attackers to bypass pa

Action: Upgrade llama-index to 0.5.2 or later.

pip install llama-index==0.5.2

Affected

introducedfixedlast affected
00.5.2-

Fixed versions

0.5.2

Sources

CVE-2025-6210 · published · modified · JSON