PyPI/picklescan CVE-2025-46417: high 7.5, EPSS 0.23%
The unsafe globals in Picklescan before 0.0.25 do not include ssl. Consequently, ssl.get_server_certificate can exfiltrate data via DNS after deserialization.
Action: Upgrade picklescan to 0.0.25 or later.
pip install picklescan==0.0.25Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.25 | - |
Fixed versions
| 0.0.25 |
Sources
- osv: PYSEC-2025-34
- nvd: CVE-2025-46417
- https://github.com/advisories/GHSA-93mv-x874-956g
- https://github.com/mmaitre314/picklescan/pull/40
CVE-2025-46417 · published · modified · JSON