PyPI/vllm CVE-2025-48887: medium 6.5, EPSS 0.54%
vLLM, an inference and serving engine for large language models (LLMs), has a Regular Expression Denial of Service (ReDoS) vulnerability in the file `vllm/entrypoints/openai/tool_parsers/pythonic_tool
Action: Upgrade vllm to 0.9.0 or later.
pip install vllm==0.9.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.6.4 | 0.9.0 | - |
Fixed versions
| 0.9.0 |
Sources
- osv: PYSEC-2025-50
- nvd: CVE-2025-48887
- https://github.com/vllm-project/vllm/security/advisories/GHSA-w6q7-j642-7c25
- https://github.com/vllm-project/vllm/commit/4fc1bf813ad80172c1db31264beaef7d93fe0601
- https://github.com/vllm-project/vllm/pull/18454
- https://github.com/advisories/GHSA-w6q7-j642-7c25
CVE-2025-48887 · published · modified · JSON