PyPI/vllm CVE-2025-48942: medium 6.5, EPSS 0.57%
vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kill
Action: Upgrade vllm to 0.9.0 or later.
pip install vllm==0.9.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.8.0 | 0.9.0 | - |
Fixed versions
| 0.9.0 |
Sources
- osv: PYSEC-2025-54
- nvd: CVE-2025-48942
- https://github.com/vllm-project/vllm/security/advisories/GHSA-6qc9-v4r8-22xg
- https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff
- https://github.com/vllm-project/vllm/pull/17623
- https://github.com/vllm-project/vllm/issues/17248
CVE-2025-48942 · published · modified · JSON