PyPI/vllm CVE-2025-29783: critical 9, EPSS 0.73%
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network inter
Action: Upgrade vllm to 0.8.0 or later.
pip install vllm==0.8.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.6.5 | 0.8.0 | - |
Fixed versions
| 0.8.0 |
Sources
- osv: PYSEC-2025-63
- nvd: CVE-2025-29783
- https://github.com/vllm-project/vllm/pull/14228
- https://github.com/vllm-project/vllm/security/advisories/GHSA-x3m8-f7g5-qhm7
- https://github.com/vllm-project/vllm/commit/288ca110f68d23909728627d3100e5a8db820aa2
CVE-2025-29783 · published · modified · JSON