PyPI/langflow CVE-2025-34291: high 8.8, exploited, EPSS 92.81%
Langflow versions up to and including 1.6.9 contain a chained vulnerability that enables account takeover and remote code execution. An overly permissive CORS configuration (allow_origins='*' with all
Action: Upgrade langflow to 1.7.0 or later.
pip install langflow==1.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.7.0 | - |
Fixed versions
| 1.7.0 |
Sources
- osv: PYSEC-2025-78
- kev: CVE-2025-34291
- https://www.vulncheck.com/advisories/langflow-cors-misconfiguration-to-token-hijack-and-rce
- https://github.com/langflow-ai/langflow
- https://www.obsidiansecurity.com/blog/cve-2025-34291-critical-account-takeover-and-rce-vulnerability-in-the-langflow-ai-agent-workflow-platform
- https://github.com/advisories/GHSA-577h-p2hh-v4mv
CVE-2025-34291 · published · modified · JSON