PyPI/simpleeval CVE-2026-32640: critical 9.8, EPSS 0.53%
SimpleEval is a library for adding evaluatable expressions into python projects. Prior to 1.0.5, objects (including modules) can leak dangerous modules through to direct access inside the sandbox. If
Action: Upgrade simpleeval to 1.0.5 or later.
pip install simpleeval==1.0.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.0.5 | - |
Fixed versions
| 1.0.5 |
Sources
- osv: PYSEC-2026-132
- https://lists.debian.org/debian-lts-announce/2026/04/msg00023.html
- https://github.com/danthedeckie/simpleeval/security/advisories/GHSA-44vg-5wv2-h2hg
CVE-2026-32640 · published · modified · JSON