PyPI/vllm CVE-2026-44223: medium 6.5, EPSS 0.37%
vLLM is an inference and serving engine for large language models (LLMs). From to before 0.20.0, the extract_hidden_states speculative decoding proposer in vLLM returns a tensor with an incorrect shap
Action: Upgrade vllm to 0.20.0 or later.
pip install vllm==0.20.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.18.0 | 0.20.0 | - |
Fixed versions
| 0.20.0 |
Sources
- osv: PYSEC-2026-145
- https://github.com/vllm-project/vllm/security/advisories/GHSA-83vm-p52w-f9pw
- https://github.com/vllm-project/vllm/pull/38610
CVE-2026-44223 · published · modified · JSON