tocsin

PyPI/llama-index-readers-obsidian CVE-2025-6210: medium 6.2, EPSS 0.33%

LlamaIndex vulnerability in its ObsidianReader class can lead to Path Traversal exploit

Action: Upgrade llama-index-readers-obsidian to 0.5.2 or later.

pip install llama-index-readers-obsidian==0.5.2

Affected

introducedfixedlast affected
00.5.2-

Fixed versions

0.5.2

Sources

CVE-2025-6210 · published · modified · JSON