PyPI/glances CVE-2026-35587: high 8.8, EPSS 0.40%
Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.4, a Server-Side Request Forgery (SSRF) vulnerability exists in the Glances IP plugin due to improper validation o
Action: Upgrade glances to 4.5.4 or later.
pip install glances==4.5.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.5.4 | - |
Fixed versions
| 4.5.4 |
Sources
- osv: PYSEC-2026-2176
- https://github.com/nicolargo/glances/commit/d6808be66728956477cc4b544bab1acd71ac65fb
- https://github.com/nicolargo/glances/security/advisories/GHSA-g5pq-48mj-jvw8
CVE-2026-35587 · published · modified · JSON