tocsin

PyPI/jupyter-server CVE-2026-40110: high 7.3, EPSS 0.31%

Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, the Origin header validation uses Python's re.match() to check incoming origins against the allow_origin_pat

Action: Upgrade jupyter-server to 2.18.0 or later.

pip install jupyter-server==2.18.0

Affected

introducedfixedlast affected
02.18.0-

Fixed versions

2.18.0

Sources

CVE-2026-40110 · published · modified · JSON