tocsin

PyPI/mlflow CVE-2026-4035: high 7.7, EPSS 0.52%

A vulnerability in mlflow/mlflow versions prior to 3.11.0 allows for the resolution of environment variables in AI Gateway secrets, which can be exploited to exfiltrate sensitive server-side environme

Action: Upgrade mlflow to 3.11.0 or later.

pip install mlflow==3.11.0

Affected

introducedfixedlast affected
03.11.0-

Fixed versions

3.11.0

Sources

CVE-2026-4035 · published · modified · JSON