PyPI/vllm CVE-2026-48746: critical 9.1, EPSS 1.15%
vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authenticat
Action: Upgrade vllm to 0.22.0 or later.
pip install vllm==0.22.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.3.0 | 0.22.0 | - |
Fixed versions
| 0.22.0 |
Sources
- osv: PYSEC-2026-226
- https://github.com/vllm-project/vllm/security/advisories/GHSA-94f4-hr76-p5j6
- https://x41-dsec.de/lab/advisories/x41-2026-002-starlette
- https://github.com/vllm-project/vllm/pull/43426
CVE-2026-48746 · published · modified · JSON