PyPI/psd-tools CVE-2026-27809: critical 9.1, EPSS 0.48%
psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to version 1.12.2, when a PSD file contains malformed RLE-compressed image data (e.g. a literal run that extends past th
Action: Upgrade psd-tools to 1.12.2 or later.
pip install psd-tools==1.12.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.12.2 | - |
Fixed versions
| 1.12.2 |
Sources
- osv: PYSEC-2026-2262
- https://github.com/psd-tools/psd-tools/releases/tag/v1.12.2
- https://github.com/psd-tools/psd-tools/commit/6c0a78f195b5942757886a1863793fd5946c1fb1
- https://github.com/psd-tools/psd-tools/security/advisories/GHSA-24p2-j2jr-386w
CVE-2026-27809 · published · modified · JSON