PyPI/pyasn1 CVE-2026-30922: high 7.5, EPSS 0.82%
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.3, the `pyasn1` library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding ASN.1 data with deep
Action: Upgrade pyasn1 to 0.6.3 or later.
pip install pyasn1==0.6.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.6.3 | - |
Fixed versions
| 0.6.3 |
Sources
- osv: PYSEC-2026-2263
- http://www.openwall.com/lists/oss-security/2026/03/20/4
- https://lists.debian.org/debian-lts-announce/2026/05/msg00001.html
- https://github.com/pyasn1/pyasn1/commit/25ad481c19fdb006e20485ef3fc2e5b3eff30ef0
- https://github.com/pyasn1/pyasn1/security/advisories/GHSA-jr27-m4p2-rc6r
CVE-2026-30922 · published · modified · JSON