PyPI/vllm CVE-2026-34756: medium 6.5, EPSS 0.42%
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lac
Action: Upgrade vllm to 0.19.0 or later.
pip install vllm==0.19.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.1.0 | 0.19.0 | - |
Fixed versions
| 0.19.0 |
Sources
- osv: PYSEC-2026-2298
- https://access.redhat.com/security/cve/CVE-2026-34756
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34756.json
- https://access.redhat.com/errata/RHSA-2026:36005
- https://access.redhat.com/errata/RHSA-2026:36006
- https://bugzilla.redhat.com/show_bug.cgi?id=2455425
- https://github.com/vllm-project/vllm/commit/b111f8a61f100fdca08706f41f29ef3548de7380
- https://github.com/vllm-project/vllm/pull/37952
- https://github.com/vllm-project/vllm/security/advisories/GHSA-3mwp-wvh9-7528
CVE-2026-34756 · published · modified · JSON