PyPI/vllm CVE-2026-47155: medium 6.5, EPSS 0.25%
vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.0, vLLM's revision pinning controls do not consistently apply to all artifacts loaded for a model. A deployment
Action: Upgrade vllm to 0.22.0 or later.
pip install vllm==0.22.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.22.0 | - |
Fixed versions
| 0.22.0 |
Sources
- osv: PYSEC-2026-2301
- https://github.com/vllm-project/vllm/security/advisories/GHSA-3ww4-5jv9-j5gm
- https://huntr.com/bounties/3f1e24c0-87d2-4f6c-a705-820f380879ac
- https://github.com/vllm-project/vllm/pull/42616
- https://github.com/vllm-project/vllm/commit/d26a28ab033697f55a1414b5b0435de7cd6045b6
CVE-2026-47155 · published · modified · JSON