PyPI/vllm CVE-2026-55646: medium 6.5, EPSS 0.52%
vLLM is an inference and serving engine for large language models. From 0.22.0 to 0.23.0, the /v1/audio/transcriptions and /v1/audio/translations routes call request.file.read() to fully materialize a
Action: Upgrade vllm to 0.24.0 or later.
pip install vllm==0.24.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.22.0 | 0.24.0 | - |
Fixed versions
| 0.24.0 |
Sources
- osv: PYSEC-2026-2305
- https://github.com/vllm-project/vllm/security/advisories/GHSA-v82g-2437-67m2
- https://github.com/vllm-project/vllm/commit/b997071ec493765abbed990c65843ed05e4708a8
- https://github.com/vllm-project/vllm/pull/45510
CVE-2026-55646 · published · modified · JSON