tocsin

PyPI/openssl-encrypt CVE-2026-74875: critical 9.8, EPSS 0.27%

openssl_encrypt versions before 1.4.0 silently skip JSON schema validation when the jsonschema library is not installed, allowing malformed metadata to be accepted. Attackers can remove the jsonschema

Action: Upgrade openssl-encrypt to 1.4.0 or later.

pip install openssl-encrypt==1.4.0

Affected

introducedfixedlast affected
01.4.0-

Fixed versions

1.4.0

Sources

CVE-2026-74875 · published · modified · JSON