tocsin

PyPI/openssl-encrypt CVE-2026-74884: high 7.5, EPSS 0.44%

openssl_encrypt versions before 1.4.0 contain a path traversal vulnerability in the _is_safe_path method where the plugin_id parameter is not sanitized before constructing the plugin config directory

Action: Upgrade openssl-encrypt to 1.4.0 or later.

pip install openssl-encrypt==1.4.0

Affected

introducedfixedlast affected
01.4.0-

Fixed versions

1.4.0

Sources

CVE-2026-74884 · published · modified · JSON