tocsin

PyPI/gitpython CVE-2026-78678: medium 6.5, EPSS 0.41%

GitPython versions before 3.1.59 contain an incomplete denylist in the unsafe_git_revision_options guard that omits --contents and -S options, allowing attackers to read arbitrary files by passing the

Action: Upgrade gitpython to 3.1.59 or later.

pip install gitpython==3.1.59

Affected

introducedfixedlast affected
03.1.59-

Fixed versions

3.1.59

Sources

CVE-2026-78678 · published · modified · JSON