PyPI/openssl-encrypt CVE-2026-74881: critical 9.3, EPSS 0.36%
openssl_encrypt versions before 1.4.0 configure CORS with allow_origins set to wildcard and allow_credentials enabled to true. Attackers can create malicious websites that make authenticated cross-ori
Action: Upgrade openssl-encrypt to 1.4.0 or later.
pip install openssl-encrypt==1.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.0 | - |
Fixed versions
| 1.4.0 |
Sources
- osv: PYSEC-2026-3977
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-c65f-x25w-62jv
- https://www.vulncheck.com/advisories/openssl-encrypt-before-cors-misconfiguration-via-wildcard-origins
CVE-2026-74881 · published · modified · JSON