PyPI/qiskit CVE-2025-2000: critical 9.8, EPSS 0.81%
Qiskit allows arbitrary code execution decoding QPY format versions < 13
Action: Upgrade qiskit to 1.4.2 or later.
pip install qiskit==1.4.2pip install qiskit==2.0.0rc2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.2 | - |
| 2.0.0rc1 | 2.0.0rc2 | - |
Fixed versions
| 1.4.2 | 2.0.0rc2 |
Sources
- osv: PYSEC-2026-510
- https://github.com/Qiskit/qiskit/security/advisories/GHSA-6m2c-76ff-6vrf
- https://nvd.nist.gov/vuln/detail/CVE-2025-2000
- https://github.com/Qiskit/qiskit
- https://www.ibm.com/support/pages/node/7185949
- https://pypi.org/project/qiskit
- https://github.com/advisories/GHSA-6m2c-76ff-6vrf
CVE-2025-2000 · published · modified · JSON