PyPI/geopandas CVE-2025-69662: high 8.6, EPSS 0.43%
SQL injection vulnerability in geopandas before v.1.1.2 allows an attacker to obtain sensitive information via the to_postgis()` function being used to write GeoDataFrames to a PostgreSQL database.
Action: Upgrade geopandas to 1.1.2 or later.
pip install geopandas==1.1.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.1.2 | - |
Fixed versions
| 1.1.2 |
Sources
- osv: PYSEC-2026-62
- https://lists.debian.org/debian-lts-announce/2026/04/msg00025.html
- https://github.com/geopandas/geopandas/pull/3681
- https://aydinnyunus.github.io/2025/12/27/sql-injection-geopandas/
- https://github.com/advisories/GHSA-6497-prx7-gpmq
CVE-2025-69662 · published · modified · JSON