PyPI/crawl4ai CVE-2026-56260, CVE-2026-56261, CVE-2026-56262, CVE-2026-56263, CVE-2026-56264, CVE-2026-56265, CVE-2026-56266: medium 6.1, EPSS 0.65%
Crawl4AI before 0.8.7 contains an arbitrary JavaScript execution vulnerability in the Docker API server's /execute_js endpoint, which accepts and executes arbitrary user-supplied JavaScript in the ser
Action: Upgrade crawl4ai to 0.8.7 or later.
pip install crawl4ai==0.8.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.8.7 | - |
Fixed versions
| 0.8.7 |
Sources
- osv: PYSEC-2026-798
- https://github.com/advisories/GHSA-g2pv-76hm-j4x9
- https://www.vulncheck.com/advisories/crawl4ai-arbitrary-javascript-execution-via-execute-js-endpoint
- https://github.com/unclecode/crawl4ai
CVE-2026-56260, CVE-2026-56261, CVE-2026-56262, CVE-2026-56263, CVE-2026-56264, CVE-2026-56265, CVE-2026-56266 · published · modified · JSON