tocsin

Debian/ndpi: critical 9.1

In nDPI through 3.2, the H.323 dissector is vulnerable to a heap-based buffer over-read in ndpi_search_h323 in lib/protocols/h323.c, as demonstrated by a payload packet length that is too short.

Action: Upgrade ndpi to 3.4-1 or later.

Affected

introducedfixedlast affected
03.4-1-

Fixed versions

3.4-1

Sources

published · modified · JSON