Debian/libgoogle-gson-java: high 7.5
The package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks.
Action: Upgrade libgoogle-gson-java to 2.9.0-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.9.0-1 | - |
Fixed versions
| 2.9.0-1 |
Sources
- osv: DEBIAN-CVE-2022-25647#Debian:13/libgoogle-gson-java
- https://security-tracker.debian.org/tracker/CVE-2022-25647
published · modified · JSON