Debian/node-undici: medium 6.5
undici is an HTTP/1.1 client, written from scratch for Node.js. It is possible to inject CRLF sequences into request headers in undici in versions less than 5.7.1. A fix was released in version 5.8.0.
Action: Upgrade node-undici to 5.8.0+dfsg1+~cs18.9.16-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 5.8.0+dfsg1+~cs18.9.16-1 | - |
Fixed versions
| 5.8.0+dfsg1+~cs18.9.16-1 |
Sources
- osv: DEBIAN-CVE-2022-31150#Debian:13/node-undici
- https://security-tracker.debian.org/tracker/CVE-2022-31150
published · modified · JSON