tocsin

Debian/cpp-httplib: high 8.8

Versions of the package yhirose/cpp-httplib before 0.12.4 are vulnerable to CRLF Injection when untrusted user input is used to set the content-type header in the HTTP .Patch, .Post, .Put and .Delete

Action: Upgrade cpp-httplib to 0.11.4+ds-1+deb12u1 or later.

Affected

introducedfixedlast affected
00.11.4+ds-1+deb12u1-

Fixed versions

0.11.4+ds-1+deb12u1

Sources

published · modified · JSON