Debian/black: medium 5.3
Versions of the package black before 24.3.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the lines_with_leading_tabs_expanded function in the strings.py file. An attacker could e
Action: Upgrade black to 24.4.0-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 24.4.0-1 | - |
Fixed versions
| 24.4.0-1 |
Sources
- osv: DEBIAN-CVE-2024-21503#Debian:13/black
- https://security-tracker.debian.org/tracker/CVE-2024-21503
published · modified · JSON