Debian/node-ip: high 8.1
The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3, 000:0:0000::01, and ::fFFf:127.0.0.1) are improperly categorized as globally
Action: Upgrade node-ip to 2.0.1+~1.1.3-3 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.0.1+~1.1.3-3 | - |
Fixed versions
| 2.0.1+~1.1.3-3 |
Sources
- osv: DEBIAN-CVE-2024-29415#Debian:13/node-ip
- https://security-tracker.debian.org/tracker/CVE-2024-29415
published · modified · JSON