Debian/node-braces: high 7.5
The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalance
Action: Upgrade node-braces to 3.0.3+~3.0.4-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.0.3+~3.0.4-1 | - |
Fixed versions
| 3.0.3+~3.0.4-1 |
Sources
- osv: DEBIAN-CVE-2024-4068#Debian:13/node-braces
- https://security-tracker.debian.org/tracker/CVE-2024-4068
published · modified · JSON