Debian/node-prismjs: medium 5.4
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can
Action: Upgrade node-prismjs to 1.30.0+dfsg+~1.26.5-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.30.0+dfsg+~1.26.5-1 | - |
Fixed versions
| 1.30.0+dfsg+~1.26.5-1 |
Sources
- osv: DEBIAN-CVE-2024-53382#Debian:14/node-prismjs
- https://security-tracker.debian.org/tracker/CVE-2024-53382
published · modified · JSON