Debian/libcrypt-urandom-perl: high 7.5
Crypt::URandom versions from 0.41 before 0.55 for Perl is vulnerable to a heap buffer overflow in the XS function crypt_urandom_getrandom(). The function does not validate that the length parameter is
Action: Upgrade libcrypt-urandom-perl to 0.55-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.55-1 | - |
Fixed versions
| 0.55-1 |
Sources
- osv: DEBIAN-CVE-2026-2474#Debian:14/libcrypt-urandom-perl
- https://security-tracker.debian.org/tracker/CVE-2026-2474
published · modified · JSON