Debian/node-markdown-it: medium 5.3
markdown-it is a Markdown parser. Versions 14.1.1 and below contain a denial-of-service vulnerability when typographer: true is enabled, due to quadratic (O(n^2)) processing in the smartquotes rule. T
Action: Upgrade node-markdown-it to 22.2.3+dfsg+~12.2.3-5 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 22.2.3+dfsg+~12.2.3-5 | - |
Fixed versions
| 22.2.3+dfsg+~12.2.3-5 |
Sources
- osv: DEBIAN-CVE-2026-48988#Debian:14/node-markdown-it
- https://security-tracker.debian.org/tracker/CVE-2026-48988
published · modified · JSON