Debian/ruby-json: low 3.7
Ruby JSON is a JSON implementation for Ruby. Versions 2.9.0 through 2.19.8 are vulnerable to heap buffer overflow when the JSON generator is provided with an oversized streamed object. When streaming
Action: Upgrade ruby-json to 2.19.9+dfsg-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.19.9+dfsg-1 | - |
Fixed versions
| 2.19.9+dfsg-1 |
Sources
- osv: DEBIAN-CVE-2026-54696#Debian:14/ruby-json
- https://security-tracker.debian.org/tracker/CVE-2026-54696
published · modified · JSON