Alpine/nodejs-current: medium 6.5
The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests. This can lead to HTTP Request Smuggling (HRS).
Action: Upgrade nodejs-current to 18.6.0-r0 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 18.6.0-r0 | - |
Fixed versions
| 18.6.0-r0 |
Sources
- osv: ALPINE-CVE-2022-32214#Alpine:v3.17/nodejs-current
- https://security.alpinelinux.org/vuln/CVE-2022-32214
published · modified · JSON